ds30 Loader free edition forums

Full Version: Wrong Pic Detected by GUI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
To All,
I am having an issue with the dspic30loader GUI program. We loaded code into a product using a dspic30F5011 with version 1.5.1 of GUI loader. We had no issues with it. We then sent the product overseas to the UK for testing purposes. A bug was found in the code and a new hex file was sent to them to boot-load into the product (which they have done to earlier revision designs without issue). I have added a screen shot of the error message, but what it states is that the GUI detected the wrong pic (PIC24HJ128GP502), not the dspic30F5011. With no errors found on my end, I decided to make sure that we both had the same software so both parties downloaded the latest version, 1.5.7. I then got the same exact error that they did. Researching the forum, I saw someone a long time ago fix a similar error by changing the settings to default. Once I did this the 1.5.7 version worked every time for my setup. The people in the UK have done the same reset to the same GUI version and still get the same error. Has anyone seen this problem and have a fix for it. Thanks in advance.
Hi,
You could try to open the %AppData%\.ds30Loader directory and delete all files there. If that doesn't solve the problem I suggest that you try a different computer and/or serial port.