ds30 Loader free edition forums

Full Version: Problem running GUI on macbook pro [solved]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I am trying to run the GUI on a macbook pro (OSX 10.7.5, USB to serial adapter) using mono. The main screen shows up but no PIC devices are loaded and the serial adapter is not found. Search all the forums and the web with no luck.

Thanks
Hi,
Thank you for the bug report. Unfortunately there is some unknown problem with Mono under MAC OS X. The same binary works in both Windows and Linux. I will post in this thread if I solve the problem.
(2012-10-26, 14:12:16)Mikael Gustavsson Wrote: [ -> ]Hi,
Thank you for the bug report. Unfortunately there is some unknown problem with Mono under MAC OS X. The same binary works in both Windows and Linux. I will post in this thread if I solve the problem.

Is there anything I can do to help out
Sure, just send me a MacBook Pro retina display CI7 2.7 16GB/768 SSD 15.4". The VMWare image has stopped working.
Thanks...I guess that means I should return the MacBook Pro retina display.

It seems to work (will test it more fully tonight on my target device)
Yeah I don't want it anymore Smile
Here is the error that is thrown when I exit out of the program...It's doesn't seem to affect the performance of the GUI but thought you may want to see it anyway

System.NullReferenceException: Object reference not set to an instance of an object
at System.Windows.Forms.ToolStripDropDownMenu.CalculateConnectedArea () [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDownMenu.OnPaintBackground (System.Windows.Forms.PaintEventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WmPaint (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStrip.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDown.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0

Unhandled Exception:
System.ArgumentException: A null reference or invalid value was found [GDI+ status: InvalidParameter]
at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in <filename unknown>:0
at System.Drawing.Graphics.GdipMeasureString (IntPtr graphics, System.String text, System.Drawing.Font font, System.Drawing.RectangleF& layoutRect, IntPtr stringFormat) [0x00000] in <filename unknown>:0
at System.Drawing.Graphics.MeasureString (System.String text, System.Drawing.Font font, Int32 width, System.Drawing.StringFormat format) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Drawing.Graphics:MeasureString (string,System.Drawing.Font,int,System.Drawing.StringFormat)
at System.Windows.Forms.TextRenderer.MeasureTextInternal (IDeviceContext dc, System.String text, System.Drawing.Font font, Size proposedSize, TextFormatFlags flags, Boolean useMeasureString) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextRenderer.MeasureText (System.String text, System.Drawing.Font font) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripMenuItem.CalculatePreferredSize (Size constrainingSize) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.GetPreferredSize (Size constrainingSize) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDownMenu.OnLayout (System.Windows.Forms.LayoutEventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.PerformLayout (System.Windows.Forms.Control affectedControl, System.String affectedProperty) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.PerformLayout () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.ControlTongueerformLayout ()
at System.Windows.Forms.ToolStripItem.OnParentChanged (System.Windows.Forms.ToolStrip oldParent, System.Windows.Forms.ToolStrip newParent) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.set_Parent (System.Windows.Forms.ToolStrip value) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItemConfusedet_Parent (System.Windows.Forms.ToolStrip)
at System.Windows.Forms.ToolStripItemCollection.Remove (System.Windows.Forms.ToolStripItem value) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDownItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripMenuItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
at System.ComponentModel.Component.Finalize () [0x00000] in <filename unknown>:0
Thank you for the report. Unfortunately I don't think there is anything I can do about it.