Search Results
Post Author Forum Replies Views Posted [asc]
    Thread: Goto bootloader written even with checkbox selected to not set it
Post: RE: Goto bootloader written even with checkbox sel...

This is odd, the posts just keep showing only your previous post. I commented out the PROT_GOTO and it appears to work as intended. I had tried setting the value to 0 and that did not appear to chan...
gcourtney 16-bit firmwares 6 11,223 2014-09-30, 15:25:33
    Thread: Goto bootloader written even with checkbox selected to not set it
Post: RE: Goto bootloader written even with checkbox sel...

Mikael Gustavsson Wrote: (2014-09-29, 14:26:05) -- I'm sorry for the late reply. You need to comment PROT_GOTO in settings.inc. --
gcourtney 16-bit firmwares 6 11,223 2014-09-29, 17:20:56
    Thread: Goto bootloader written even with checkbox selected to not set it
Post: RE: Goto bootloader written even with checkbox sel...

I should mention I have tried it both with and without the bootloader firmware protection set to 1 in the settings.inc file.
gcourtney 16-bit firmwares 6 11,223 2014-09-24, 21:38:17
    Thread: Goto bootloader written even with checkbox selected to not set it
Post: Goto bootloader written even with checkbox selecte...

I am jumping to the bootloader from the program so I do not run the bootloader at power up. Even though I have the "Don't set goto BL at 0x00" box checked, it seems to do it anyway. I checked the he...
gcourtney 16-bit firmwares 6 11,223 2014-09-24, 21:09:42
    Thread: Bootlader single steps but resets when trying to run
Post: RE: Bootlader single steps but resets when trying ...

I found the cause of this odd behavior and a solution for the very short term, until I can get the system to assign the initial conditions properly. The problem is caused by the SPLIM register. With a...
gcourtney 16-bit firmwares 2 5,417 2014-09-09, 21:53:20
    Thread: Bootlader single steps but resets when trying to run
Post: Bootlader single steps but resets when trying to r...

I have an odd problem when trying to load and run the DS30 bootloader. I am using MPLAB X IDE v2.10, xc16 with an IDC 3 on a dsPIC33FJ64GP706A with a 16 MHZ Xtal. Using RS-232 and 38400 to try to pr...
gcourtney 16-bit firmwares 2 5,417 2014-09-09, 19:54:55