Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible GUI bug [solved]

I have been looking at the ds30 loader GUI and I think I have found a bug, or at least I don't understand whats happening.
I am using a 12F1840 part and the bootloader is identified and works however, the bootloader start address in debug mode and the graphical representation appears to be wrong.

Using the default bootloader placement (BLPLW) of 256, after the device has been programmed I pull the flash from the device and the bootloader starts at F00. But the debug mode in the GUI with custom bootloader unticked says start address of 0xF40.

Also toggling the custom bootloader selection on and off with a placement of 6 pages from end, it doesn't show a change in the graphical representation, however F00 (the default) is 8 pages from the end.

The only reason I spotted this was I reduced the placement to 192, to make use of a little more space. And was having trouble finding the right settings for the loader gui. Does anyone else see this?


Messages In This Thread
Possible GUI bug [solved] - by Wipster - 2012-11-02, 18:54:50
RE: Possible GUI bug - by Mikael Gustavsson - 2012-11-03, 22:20:05
RE: Possible GUI bug - by Wipster - 2012-11-05, 11:43:01

Forum Jump:

Users browsing this thread: 1 Guest(s)