Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to find a version of runtime
I've put together a small PIC30F5011 module that has CAN bus on one side and RS485 for DMX-512A on the other. 

A small FTDI USB to TTL dongle can be plugged in for configuration.  It's used to translate DMX-512A light show information from the S4 Light-O-Rama program for Christmas Lights.  The lights are re-purposed 2010 Olympic Ring Lights.

ORing Light Demo

On my WIN-7 system I can use the ds30Loader Free version to update the firmware over the USB to TTL interface.

The PC I've dedicated to running the LOR software is an older WIN-XP 32 bit system.  I've installed .net 4.0 but as soon as I run the loader I get a dialog with the following message:

"Unable to find a version of the runtime to run this application."
The title bar of the dialog is
"ds30 Loader GUI.exe - .NET Framework Initialization Error"

The version of the loader is dated from 2010.

What am I missing?  I can't find a .NET 2.0 from Microsoft for WIN-XP.

Attached Files Thumbnail(s)
Have you tried

Forum Jump:

Users browsing this thread: 1 Guest(s)