Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem flashing firmware of USB module with PIC24FJ256GB106 on board

I recently bought this USB HID host module, which has on board a 24FJ256GB106 PIC (manual ). I have soldered pins onto j2 connector, and connect txd (to the rxd of a usb to serial adapter) ,rxd (to the txd of a usb to serial adapter),+5v and ground, the led on the module turns red (which means that it's powered on). I also put pins to Mclr and ground signals of the j3 connector, in order to initiate program mode of pic.
I've tried ds30loader under win xp, but unfortunately every time i tried to flash the hex file, ds30loader wrongly recognize the 24FJ pic as dsPIC30F series. If i put 24FJ256GB106 by hand then it gives me a wrong pic selection message! I also know that usb to serial works ok, because i have successfully managed to flash a firmware to a gotek usb floppy emulator.

So, is there anything i can try/do?
Please zip and post your boot loader project.
Have you selected UART operation with the jumper?
Do you have working serial communication with your application?
According to module's manual uart mode is preselected since the pgd pin is not connected to gnd.You can find all availiable software and the hex files from vendor here there are both hex files and source codes. Mostly i'm interested to falsh MB-CM13111_1 which is for usb hosting mouse/keyboard.
I also just tried a real com port which is onboard my motherboard. This time, when i tried to flash the module i got:     (i instantly put mclr to gnd to get this, otherwise can't find bootloader)
Also this is what iget on vendor's com assistant program:
Quote:Please zip and post your boot loader project.

Forum Jump:

Users browsing this thread: 1 Guest(s)