Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Wrong pic detected [solved]
I am having problems with GUI 1.3.12 and it not correctly detecting the pic chip. When I use the console application it successfully connects and uploads the code. With the GUI however I receive the following response:
echo verification failed ( 0) 0xC1/0xF1
Found dsPIC30F3014 fw ver. 1.1.0
Wrong pic detected(1)/selected(241), aborting

If I go to the Terminal tab in Advanced Mode and send 0xC1 the response I receive is: 0xF1 0x01 0x11 0x4B. The 0xF1 (241) would be confirming it is receiving the correct device id.

The hardware being used is an pic24fj256GB106 connected via UART to an MCP2200 (Microchip UART to USB) at 19200 baud.

Thanks for a great bootloader !
Why did you enable echo verification? Did you read about in the manual?
I did not enable echo verification, when I look under the Advanced Tab this option is set and greyed out, I am unable to change this option and remove as is ?

I have used the Options->Reset all settings to default and this has cleared the echo verification setting. Probably something I should have done before. It now correctly detects the pic.

Not sure why it became set or as to why I was unable to clear it. I had been trying multiple ds30 Loader GUI to try and resolve my problems so may have done something to the registry in the process ????

Anyway resolved and thanks for your response.
That's weird. Probably a problem with the settings file when switching between versions but I'm not sure.
But I'm glad it worked out for you.

Forum Jump:

Users browsing this thread: 1 Guest(s)