Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Found Unknown Device
Hi guys,

I am facing a (hopefully) small problem when using the ds30loader.
When I try to update the firmware using the application I made (Visual Basic application) which uses the ds30loader, I keep getting the message that the device found is the wrong one. I also tried to use the basic application provided in the package and the free GUI application on line and it yielded the same result.
The device whose firmware I want to update is a PIC24FJ device but the device 'found' by the program is a dsPIC30F one.
The baud rate and other settings are correct. Although, when I try to use different firmware HEX files, some HEX files are successfully parsed with no errors while, sometimes, there are unknown data found. I am guessing that this is the result of the device not being the right one. There are also other small errors (sometimes), which I am guessing are results of the detection of the wrong device as well.

Are there any solutions to this problem? Is this just a current glitch or is this a fault in the hardware?

I also tried to update the firmware of PIC18F and PIC18FJ devices in the same board (or connected to it) but I was faced with the same problem.

Thanks in advance!

EDIT: Apologies if there are some missing details, just state which ones are needed and I will display them as soon as possible. I will try to describe them meticulously.
The most likely problem is that the oscillator and/or baud rate is not setup correctly. Please zip the entire MPLAB IDE boot loader project and post it here. Also post a screenshot of the GUI as you have configured it.

Forum Jump:

Users browsing this thread: 1 Guest(s)